前台参数（licence_p.ini）

1、添加is_use_clcx控制是否使用超量促销(1=使用 0=不使用)------新西兰的用户的小数点是逗号，与中文小数点不同，所以有些东西会区分出去，因此加了一个参数控制。

2、参数is_disp_spbm(1=显示商品编码 0=显示商品条码)，控制零售单明细显示商品编码还是商品条码。

3、增加折扣卡遇到不打折商品时,读商品会员价(hyk_flag   0=读商品的正常价格  1=读商品的会员价)

4、 list_update_date控制前台是否显示编译日期(1=显示 0=不显示)

5、增加参数(pos_use_czk_only)，控制前台只允许使用储值卡(1=只允许使用储值卡 0=正常使用)

6、增加参数(pos_login_qxk)，控制前台登陆是否采用权限卡(1=使用权限卡 0=不使用权限卡)。

7、增加电子称商品的计件参数值的控制，默认Licence_p.ini中[pos]下dzc_parm=0.01

8、 is_must_print_driver控制前台是否使用双打印机，也就是本地打印，然后在网络中连接一个打印也打印,主要用于餐饮的厨打 (1=打印 0=不打印)

9、 hyk_user_spzk控制前台使用会员卡后是否还享用商品资料中自带的折扣(1=使用 0=不使用)、

10、 is_print_czk_kkzz控制前台使用储值卡卡卡转帐是否打印每张卡的余额，并且在交班时候是否打印卡余额为0的卡张数(1=打印 0=不打印)

11、 print_big_dh控制是否把单号打印为大字体格式(1=是 0=不是)

12、 is_use_czk_xf控制是否可以使用储值卡进行结算(1=可以 0=不可以)

13、 list_hyj控制在收银界面是否显示会员价(1=显示 0=不显示)

14、 print_bm_fs控制小票打印为商品编码还是商品条码还是编码条码都不打(bm=商品编码 barcode=商品条码 no=都不打)

15、 print_czk_count控制使用储值卡打印小票的份数

16、 list_p_eng控制是否可以查看到参数设置中显示是否打印英文的选项(1=可以查看到 0=不可以查看)

17、 is_list_server_name控制软件的下方是否显示服务器名(1=显示 0=不显示)

18、 sk_defalut_je来控制收款界面中的实收金额是否默认当前收款金额(1=默认 0=不默认)

19、 gkp_list_lx来控制每扫描一个商品显示的内容是什么(dj=显示当前商品的单价 je=显示消费的总金额)

20、 print_title_end来控制小票标题是打印顺序(1=当前交易打印后在打印 0=在当前交易打印前在打印)

21、 print_sp_kh来控制每打印完一个商品后打印多少空行(0=不打印空行 N=打印N空行)

22、 is_print_je_ls来控制是否打印原零售价金额(0=不打印 1=打印)

23、 close_exp控制前台进系统后是否关闭Window的系统功能键(1=关闭 0=不关闭)

24、 print_bm_fs控制小票打印为商品编码还是商品条码(bm=商品编码 barcode=商品条码)

25、 print_count_time控制收款后在每张小票打印完和开始的停顿时间，方便撕纸(n=n秒 0=不停顿)

26、 print_count控制收款后在原有一张小票的基础上在打印几张小票(n=n张 0=没有)

27、 down_jbzl_fs控制基本数据下载的方式，支持两种(第一是: >(只下载增量数据) 第二是: >=(只下载完整增量数据))

28、 gwq_auto_ml来控制前台使用购物券收款时是否自动抹零 (1 =抹零 0=不抹)

29、 is_print_hyk_jf_now控制是否打印当前单的积分(1=打印 0=不打印)

30、 print_hyk_mc控制打印会员卡号的名称(空字符=会员卡号:)

31、 close_turnoff控制前台退出时是否一定要关机(1=是 0=否)

32、 edit_sl_mode控制更改数量的模式(add=在原来是数量上增加，rewrite=已当前的修改数量覆盖原来数量)

33、 is_list_qx_je控制钱箱取款时是否显示钱箱当前金额(0=不否以 1-是否)

34、在进入系统后可以按Ctrl+F11键可以设置licence_p.ini文件中的软件配置

35、通过is_print_zk_je控制在交班清款单是否打印总折扣金额(1=打印，0=不打印)

36、 is_sk_dfs控制是否同时使用四种收款方式来收银(0=不可以 1=可以)

37、 is_spbm_abc来控制查询商品编码是否可以包含字母(0=不可以 1-可以)

38、 print_qx来控制在交班清款时是否打印钱箱的收支情况(0不打印 1=打印)

39、 check_db来控制已当班的收银员但未交班是否下一班收银员可进入系统收银(0=不可以收银 1=可以收银)

40、 is_fkc_xs来控制前台是否的允许负库存销售(0=不可以 1=可以)

41、 is_no_price_sale来控制单价为零是否可以销售(0=不可以 1=可以)

42、 is_print_zyh来控制是否打印总优惠金额(0=不打印 1=打印)

43、 is_print_zyh来控制是否打印总优惠金额(0=不打印 1=打印)

44、 is_print_sp_yj来控制当促销时候是否打印商品的原零售价格(0=不打印 1=打印)

45、 zk_zd_all_sp来控制在输入整单折扣后的商品是否也享受整单折扣(0=不享受 1=享受)

46、 is_enter_sk来控制是否可以使用回车键来收款(0=不可以 1=可以)

47、可以 is_print_czk_ye是否打印储值卡余额(0=不打印 1=打印)

48、可以 is_print_hyk_jf是否打印会员卡积分(0=不打印 1=打印)

49、可以 is_print_hyk是否打印会员卡号码(0=不打印 1=打印)

50、 re_unload_dj_update_czk来控制重新上传零售单据是否更新储值卡的金额(0=不更新 1=更新)

51、 hyk_user_sdcx来效验使用会员卡是否使用时段促销价格(0=不使用 1=使用)

52、 is_check_dj_min来效验是否可以低于最低售价(0=不效验 1=效验,如低于最低价不允许销售 n=效验,如低于最低价提示)

53、 is_use_xlcx来控制是否使用限量促销(1=使用 0=不使用)

54、 is_use_czk_jf来控制使用储值卡当前单是否积分(0=不积分 1=积分)

55、 is_input_card_n来控制前台会员卡，储值卡是否可以手工输入(1=可以 0=不可以)

56、 is_print_after_sk来控制开单后是否立即打印,如果选择不打印可以按补票打印(1=立即打印 0=不打印)

57、 print_jbr_title来控制前台是否打印营业员(空('')=不打印 任意字符('营业员：')=表示打印为(营业员： + 营业员名称))

58、 print_kh_title来控制前台是否打印客户(空('')=不打印 任意字符('客户：')=表示打印为(客户： + 客户名称))

59、 is_add_kh来控制是否可以在联网状态下新增客户资料(0=不可以 1=可以)

60、 is_czk_use_pass来控制前台储值卡是否使用密码管理(0=不使用 1=使用)

61、 is_check_server_date来控制前台的日期和后台日期不同是否可以收银(0=可以收银 1=不能收银)

62、 barcode_find_digit来控制使用条码的后几位来检索商品，是为了方面手工输入条码(0=此功能无效 n=通过条码最后的n位检索商品)

63、 check_last_day来控制每月的最后天如果有单据未上传是否可以退出系统(1=不能 0=可以)

64、前台增加front=? back=? 来控制输入的储值卡的取数位数,如：front=1 back=1表示输入的储值卡第一位和最后一为无效

65、修改前台如果商品不允许打折，有会员卡时取会员卡的折扣。(licence.ini->pos->sp_hyk_zk, 0不生效，1为生效)

66、增加前台ini文件参数is_disp_spbm(1=显示商品编码 0=显示商品条码)，控制零售单明细显示商品编码还是商品条码

67、修改前台如果商品不允许打折，有会员卡时取会员卡的折扣。(licence.ini->pos->sp_hyk_zk, 0不生效，1为生效)

68、关闭银行卡收银栏(用参数据控制是否显示，默认值为显示，bank_sk_visible 0显示， 1不显示)

69、当优惠金额为负数时选择是否打印。前台增加参数：print_yh_je=0打印，1为不打印默认打印

70、使用购物券消费时，顾客必须购买正价商品。增加参数,licence_p.ini ->pos_gwq_skcx=1生效,默认不生效.

71、前台增加参数，licence_p.ini ->show_xxms=1显示并打印练习模式（默认）；0不显示、不打印

72、增强前台营业员选取统一用CTRL+A来选择,如果要选择营业员，统一按CTRL+ A来选择，（licence_p.ini ->pop_yyy=1 为营业员商品一对一，pop_yyy=0为一张单对应一个营业员）

73、pos_check_version=是否检查前后台的版本号(1=检查 0=不检查)

   前台加参数控制小票打印是否打印单号

   print_big_dh =1 （原来已有的是否要换行打印的）

   print_dh=0 （新加的, 默认为1打印）

74、交班清单打印多次在licence_pos.ini ->pos 中加参数

    print_day_time=1(1表示打只打印一次，2表示打印2次)

75、修改后台做限量促销单,更改商品的新会员价,前台用会员卡销售,限量促销单中的会员价取不出来,取出来的是限购的零售价。
  licence_p.ini
  [pos]
  use_xlcx_hy_dj=1为不取会员价，use_xlcx_hy_dj=0为取会员价，默认取会员价

76、前台通过参数控制迪宝直连称重是否可以同时称多个商品。(is_no_dzc_sllj=1表示可以，0不可以）

77、修改了在零售→会员积分规则设置→单品积分设置规则中“分别设置同一个商品，不同包装是否积分不起作用”的问题。
   在licence_p.ini中增加了参数控制：hyk_dw_jf是否分别设置同一个商品，不同包装是否积分（1=是 0=否）

78、前台新增一个参数，找零大于100仍可以收款:修改增强版前台 参数：lince_p ->pos->sk_100=1

79、按F2用储值卡收款的时候自动读卡的参数：pos_czk_auto_read=1

80、是否允许前台手工输入储值卡号：
   在lincence_p.ini->master->
   is_input_card_n=1 会员卡可以手工输入（=0，会员卡不可以手工输入）
   is_input_card_czk_n=0 储值卡不可以手工输入（=1储值卡可以手工输入）

81、前台开单的套打小票流水号要以年月加流水号（如LS201012—00001）不要显示日，另外是流水号要求一个月更新一次。
    在前台增加参数：lincence_p->pos->dh_no_day=1

82、把IC卡做成权限卡，但是在权限输入的对话框中没有读卡的按钮，在lincencn_p.ini下加pos_login_qxk=1；

83、在前台增加一个功能键（CTRL+T），可以转化商品的大小包装，输入1为基本单位，2为小包装，3为大包装

84、在小票上可以打印本单积分，在licence_p.ini中设置is_print_hyk_jf_now = 1就可以打印

85、文具行业，销售的时候是不用商品编码销售，直接用助记码销售，加参数，前台商品销售不因助记码、条码中的数字相同出现混淆（注：助记码中的数字字长不能等于或者大于条码规定的数字字长）。
licence_p.ini下加pos_spxs_mode=zjm


后台参数控制（licence.ini）
1、[master]fb_hyk_xlcx=1控制分部可以做会员限购单。(1＝分部可以做会员限购单 0＝只有总部可以做会员限购单)-------此功能是单独为玉林天宇做的，除了加此参数外，要手动删除用户帐套remote_a_need_project中的jxc_bm_hyk_xlcx表。

2、[master]is_cube=0（1=原来方法 0=cube）增加licence.ini文件参数, 控制商品库存状况报表使用CUBE控件报表还是用回原来的方法。----由于此控件使用在增强版都报错,所以从5月9日以后的版本都没有参数控制

3、[master]fb_gh_jh=0(0＝分部不取进价 1＝分部可以取进价)，将参数放到分部的licence.ini文件中，增加参数控制分部进货单是否可以读取总部商品进价。。-------玉林天宇提出来的要求。

4、is_use_clcx控制是否使用超量促销(1=使用 0=不使用)-----玉林天宇

5、is_pfgl_rzdy(1=入帐后才允许打印 0=不限制)，控制批发类单据是否要入帐后才允许打印------惠雅超市2009-05-29

6、通过参数控制批发，配送出库单等是否支持电子秤扫描录入
ck_support_dzc 1=支持 0=不支持
dzc_sl_digit = 2 控制扫入数量的小数位
dzc_dj_digit = 2 控制扫入单价的小数位
dzc_je_digit = 2 控制扫入金额的小数位

7、[master]fb_hyk_xlcx 控制分部可以做会员限购单。(1＝分部可以做会员限购单 0＝只有总部可以做会员限购单)

8、在批量写卡时有参数控制是否弹出提示, 因为非接触卡没有等待触发功能，如果没有message提示， 则会很快过去,来不及放卡(Licence.ini->master->card_mess 0为不生效， 1为生效)
   增加参数(jh_no_xs_data=1 0显示 1不显示)控制采购单是否显示销售统计数据(周销售量、月销售量、最后销售日期)

9、增加参数（mlhs_zhjh=1），控制毛利报表是否有按最后进价核算的功能。

10、增加自动生成销售数据功能，用参数控制（gen_xs_data=1）

11、增加参数控制（dj_zero_del=1），采购进货单保存时自动删除进货数量为零的商品明细。

12、增加参数控制（find_column=mc,xm），报表查询字段可自动模糊查询。

13、通过参数fb_sdcx控制分部可不可以自己开时段促销单(1=可以 0=不可以)

14、通过参数spbm_edit_tj控制在商品资料修改状态下是否可以修改商品的特价(1=可以 0=不可以)
通过参数spbm_edit_fc控制在商品资料修改状态下是否可以修改商品的分仓价格(1=可以 0=不可以)

15、pd_zmsl控制盘店单帐面数量显示

16、通过dzc_gs_bs参数来控制导出顶尖电子秤是按重量还是按个导出，更加商品的单位来最判断,比如值为: 个,块  那么商品单位为(个)和(块)的全部用按个单位导出

17、pf_check_xyed参数来控制批发开单当客户超过信用额度是否可以保存(1=可以，0=不可以)

18、通过参数is_list_hycx控制在导行图中是否显示会员和促销模块(1=显示 0=不显示)

19、通过参数is_list_server_name控制软件的下方是否显示服务器名(1=显示 0=不显示)

20、通过参数show_gh_tj_rq来控制在开采购进货单中零售价格与特价的日期差, 如=5,今天是2007-9-10,那么如果此商品在2007-9-15如果有特价的话,那么零售价就读取为特价,反之就读商品资料的零售价格

21、通过参数sp_asneeded来控制打开商品资料时候是否浏览出所有的商品数据(no=浏览全部商品，但是速度慢 yes=浏览部分商品，需要看其他商品手工翻页)

22、通过参数client_jzxy来控制客户端是否允许做结转下月操作(1=允许 0=不允许)

23、通过参数is_show_gather控制在单据中是否显示汇总(1=显示, 0=不显示)

24、通过参数sp_kcxxts来控制销售单保存时是否提示当前商品低于库存下限(1=提示,0=不提示)

25、参数sp_edit_colse来控制商品修改保存后是否修改商品的界面(1=不退出 0=退出)

26、通过参数is_fcdy来控制盘点单保存后，是否打印一份与帐面数不同的明细表(1=打印要,0=不打印)

27、通过参数is_fcdy控制输入盘点单后是否进行盘店复查(0=不复查 1-复查)

28、通过参数input_gys来控制商品新增时是否一定要输入供应商(0=可以不输 1=一定输入)

29、通过参数is_spbm_abc来控制查询商品编码是否可以包含字母(0=不可以 1-可以)

30、通过参数is_save_jh_not_gys来控制进货商品不是当前供应商是否可以输入(0=不可以 1=可以)

31、在采购订单，进货单中可以通过sp_xx_info=0在商品详细信息中看到当前商品所有供应商的报价

32、通过参数auto_dj_add_sl来控制在开单中选择默认数量为1的选项后碰到相同商品是否自动累加还是提示( 0=提示 1=自动累加)

33、通过参数auto_make_barcode_13来控制商品资料当输入条码12位时候回车是否读取第13位效验码( 0=不读取 1=读取)

34、通过参数rep_find_mode来控制报表查询模式(0=打开报表自动查询出数据 1=打开报表先输入查询条件查询数据)

35、通过参数exp_excel_mode来控制数据倒出到Excel的方式(0=完整导出 1=快速导出)

36、通过参数is_select_zt来控制是否显示帐套选择界面(0=不显示 1=显示 )

37、可以通过参数is_pd_exist_wgzdj来控制有未过帐的零售单据是否可以开始盘点(0=不可以盘点 1=可以盘点)

38、可以通过参数sp_input=1;1;1 来控制商品录入时的数据项(Tab)是否显示

39、可以通过参数main=1;1;1 来控制菜单的项目是否显示

40、可以通过参数is_jh_update_gys来控制进货是否更新商品的供应商(0=不更新 1=更新 )

41、可以通过参数is_jh_update_dj来控制进货是否更新商品最后进价(0=不更新 1=更新 )

42、可以通过参数is_edit_dzc_bm来控制新增称重商品时是否可以自行更改编码(0=不能 1=可以)

43、可以通过参数is_srf_change来控制商品输入的输入法是否自动切换(0=不自动切换 1=自动切换)

44、可以通过参数is_czk_use_pass来控制储值卡是否使用密码管理(0=不使用 1=使用)

45、后台所有单据通过参数barcode_find_digit来控制使用条码的后几位来检索商品，是为了方面手工输入条码(0=此功能无效 n=通过条码最后的n位检索商品)

46、通过参数check_jzxy控制本月没有业务单据是否可以结转下月(1=可以 0=不可以)

47、后台盘点输入可以通过参数barcode_find_digit来控制使用条码的后几位来检索商品，是为了方面手工输入条码(0=此功能无效 n=通过条码最后的n位检索商品)

48、后台通过is_update_hand参数来控制是否可以用ctrl+F12键手工执行数据修改功能(1=可以，0=不可以)

49、前台增加用参数check_login_date来控制前台进入日期小于上次收款日期是否可以进入前台收银系统(1=不可以  0=可以)

50、[master]is_newpf_rzts(1＝提示过账 0＝不提示)控制批发单据新增保存是否提示过账。----惠雅需求

51、[HY_TAB]
   0:隐藏;1:显示
   JTCY=1
参数控制会员资料增加家庭成员生日信息及生日报警功能。

52、增加ini文件参数is_zyfb_kcbs(1=有库存报损 0=无库存报损)，控制直营分店是否具有库存报损功能。

53、增加控制商品资料浏览时分页控制，licence.ini 增加参数数控制，(master-> sp_asneeded=no 全部， yes 部份)

54、增加ini文件参数is_pfgl_rzdy(1=入帐后才允许打印 0=不限制)，控制批发类单据是否要入帐后才允许打印。

55、在批量写卡时有参数控制是否弹出提示, 因为非接触卡没有等待触发功能，如果没有message提示， 则会很快过去面来不及放卡(Licence.ini->master->card_mess 0为不生效， 1为生效)

56、增加ini文件参数，控制批发单据新增保存是否提示过账。[master]is_newpf_rzts(1＝提示过账 0＝不提示)

57、增加ini文件参数is_zyfb_kcbs(1=有库存报损 0=无库存报损)，控制直营分店是否具有库存报损功能。

58、增加控制商品资料浏览时分页控制，licence.ini 增加参数数控制，(master-> sp_asneeded=no 全部， yes 部份)

59、单据商品编码重复时根据参数[master] rep_sp_hint 来提示。[1 yes 0 false]

60、在批发订单里面的单据里面对于扫描的商品(条码，编码) 默认为1，且能够连续扫描后累加（licence.ini ->master->auto_dj_add_sl , 0为提示，1为不提示）。

61、效验商品是否属于当前供应商是否要提醒(is_gys_popo, 1为不提醒，0为提醒，默认为提醒)

62、商品资料显示界面增加参数分部是否显示商品类别功能。参数：show_sp_all= 0不生效，1生效。

63、前台加一参数控制一卡通按F7输入会员卡后，不显示下面储值卡的明细, show_czk=1 不显示，0为显示

64、顶尖电子秤加参数dzc_fs_add1，该参数开启时候商品编码位减1，金额位加1，建商品档案的时候也相应的减少一位，所以请开启这个参数再建商品档案，否则可能导致取价错误，该参数是否可见由
[pos_dzc]
dzc_fs_add1=1控制

65、在ini参数中增加一个当前电脑默认仓库比如：bm_ck_defalut=01

66、零售商品毛利表，参数控制是显示按移动均权核算毛利还是最后进价算选项，mlhs_zhjh（1=按移动均权核算毛利，0=最后进价算）

67、在ini参数中增加一个只单独显示会员卡与零售价的参数，即用会员卡时是否要显示零售价：如果有会员卡就不显示零售价，如果没有会员卡，只显示零售价不显示会员价：    hyk_ls_visible=1;

68、在ini参数中增加一个使用权限卡控制参数：login_qxk=1

69、在ini参数中增加一个控制储值卡是否手工输入的参数：is_input_card_czk_n=0储值卡不可以手工输入（=1，储值卡可以手工输入）

70、销售开单：lincence.ini ->master->show_bm_dw=1不生效，=0生效，默认取上一单的值

71、在销售开单，客户名称，加参数控制，默认上一条记录，在Licence.ini里exp_excel_mode=1改成等于0就可以了

72、收银员交班手款单实收金额比应收金额多的情况下，是否可以保存， 增加参数：licence.ini->master->pos_js_sk_je=1不控制，pos_js_sk_je=0控制,

73、增加了后台会员卡信息处把电话改为入所编号，前台查询条件中把电话改为入所编号的功能，在licence_p.ini -pos中添加参数：czk_je_xf_kz=1生效，czk_je_xf_kz=0不生效。

74、增加了当储值卡每天消费到一定金额时，系统给予提示的功能。在licence_p.ini ->pos中添加参数：czk_je_xf_kz=1的前提下，再添加参数：czk_je_xf，此参数的值可以为 任意值。